summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-15 16:02:43 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-15 16:02:43 -0600
commite67118adb4a6faf4d442ccc1d3042be522b8d0c5 (patch)
tree129878368ff7972716000e3c7e2f6e59d08cc1d3 /gnu/packages/emacs-xyz.scm
parent099ce5d4901706dc2c5be888a5c8cbf8fcd0d576 (diff)
downloadpatches-e67118adb4a6faf4d442ccc1d3042be522b8d0c5.tar
patches-e67118adb4a6faf4d442ccc1d3042be522b8d0c5.tar.gz
gnu: Add emacs-hide-mode-line.
* gnu/packages/emacs-xyz.scm (emacs-hide-mode-line): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7ea8032b79..8212e4d5b9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20574,3 +20574,24 @@ It uses parseclj's shift-reduce parser internally.")
It supports several input and output formats, all powered by the
same shift-reduce parser function.")
(license license:gpl3+)))
+
+(define-public emacs-hide-mode-line
+ (package
+ (name "emacs-hide-mode-line")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hlissner/emacs-hide-mode-line.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dfzjgxfkcw4wisbyldsm1km18pfp9j8xgadn6qnsz11l55bpgyp"))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs plugin that hides the mode-line")
+ (description "A minor mode that hides the mode-line in your current
+buffer. It can be used to toggle an alternative mode-line, toggle its visibility,
+or simply disable the mode-line in buffers where it is not very useful.")
+ (home-page "https://github.com/hlissner/emacs-hide-mode-line")
+ (license license:expat)))