summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-02 17:12:05 -0400
committerMark H Weaver <mhw@netris.org>2018-06-04 21:19:35 -0400
commit8b71684a2086182528c16b5e21599013420ea84c (patch)
treee061e5c1901fc5a9b7e41592deaea5c1b998ede2 /gnu/packages/elf.scm
parent7394e264fced0d17dcbe98881624be8fa83165e3 (diff)
downloadpatches-8b71684a2086182528c16b5e21599013420ea84c.tar
patches-8b71684a2086182528c16b5e21599013420ea84c.tar.gz
gnu: elfutils: Disable test suite on MIPS.
* gnu/packages/elf.scm (elfutils)[arguments]: Add (#:tests? #f) on MIPS.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index eaa9ab5f51..9b120751d2 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -56,6 +56,14 @@
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
+
+ ;; Disable tests on MIPS (without changing
+ ;; the arguments list on other systems).
+ ,@(if (string-prefix? "mips" (or (%current-target-system)
+ (%current-system)))
+ '(#:tests? #f)
+ '())
+
#:phases
(modify-phases %standard-phases
;; No reason has been found for this test to reliably fail on aarch64-linux.