summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-21 19:57:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-21 21:14:36 +0200
commiteb9a603317c4b8a77079f0a9ebd3ea802a0ed8df (patch)
tree2fccaebcc3018fcc5372a14b69013d76a8b97fad /gnu/packages/elf.scm
parent6d755c7b8482cf013b6c68eadb572320a4f091f2 (diff)
downloadpatches-eb9a603317c4b8a77079f0a9ebd3ea802a0ed8df.tar
patches-eb9a603317c4b8a77079f0a9ebd3ea802a0ed8df.tar.gz
gnu: libelf: Support aarch64.
* gnu/packages/elf.scm (libelf)[arguments]: Modify custom configure phase to declare host type on aarch64.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 35b644906b..95ba7618a1 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -78,7 +79,7 @@ addr2line, and more.")
(base32
"0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
(build-system gnu-build-system)
- (arguments '(#:phases (alist-replace
+ (arguments `(#:phases (alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
;; This old `configure' script doesn't support
@@ -87,7 +88,12 @@ addr2line, and more.")
(setenv "CONFIG_SHELL" (which "bash"))
(zero?
(system* "./configure"
- (string-append "--prefix=" out)))))
+ (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())
+ ))))
%standard-phases)))
(home-page "http://www.mr511.de/software/english.html")
(synopsis "ELF object file access library")