summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-24 20:35:37 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-24 20:35:37 +0100
commitb655b2154c8a72f5c9b7e54594653df49f3c2c02 (patch)
tree51ecf5c6580dfddd0a6b8403dd5284850f0fed56 /gnu/packages/ebook.scm
parent2c16316ef4420b462a1147e8eaee4680093616fd (diff)
downloadpatches-b655b2154c8a72f5c9b7e54594653df49f3c2c02.tar
patches-b655b2154c8a72f5c9b7e54594653df49f3c2c02.tar.gz
gnu: calibre: Add a patch to avoid automatic checking for updates.
* gnu/packages/patches/calibre-no-updates-dialog.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch. * gnu/packages/ebook.scm (calibre): Use patch.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index de85fad8c6..05165774d7 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -77,7 +77,8 @@
'(begin
(delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")))
- (patches (list (search-patch "calibre-drop-unrar.patch")))))
+ (patches (list (search-patch "calibre-drop-unrar.patch")
+ (search-patch "calibre-no-updates-dialog.patch")))))
(build-system python-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)