summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-05-14 17:01:06 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-05-19 23:49:21 +0200
commitaffaf98f7747347e6be28aa9ebf54a0509ca5155 (patch)
tree8fbc04fcac006ca5fd13235c330cbddea6c66e03 /gnu/packages/ebook.scm
parent9b7dcc27031ddad451d75ed85a5681ff2210be00 (diff)
downloadpatches-affaf98f7747347e6be28aa9ebf54a0509ca5155.tar
patches-affaf98f7747347e6be28aa9ebf54a0509ca5155.tar.gz
gnu: calibre: Add exhaustive license list.
* gnu/packages/ebook.scm (calibre): Add exhaustive license list. (chmlib)[license]: Use license: prefix. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index bf80d6650e..9db553620d 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -20,7 +20,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages ebook)
- #:use-module ((guix licenses) #:select (gpl3 lgpl2.1+))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -60,7 +60,7 @@
(home-page "http://www.jedrea.com/chmlib/")
(synopsis "Library for CHM files")
(description "CHMLIB is a library for dealing with ITSS/CHM format files.")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public calibre
(package
@@ -167,4 +167,16 @@ and catalog ebooks in most of the major ebook formats. It can also talk
to many ebook reader devices. It can go out to the Internet and fetch
metadata for books. It can download newspapers and convert them into
ebooks for convenient reading.")
- (license gpl3))) ; some files are under various other licenses, see COPYRIGHT
+ ;; Calibre is largely GPL3+, but includes a number of components covered
+ ;; by other licenses. See COPYRIGHT for more details.
+ (license (list license:gpl3+
+ license:gpl2+
+ license:lgpl2.1+
+ license:lgpl2.1
+ license:bsd-3
+ license:expat
+ license:zpl2.1
+ license:asl2.0
+ license:public-domain
+ license:silofl1.1
+ license:cc-by-sa3.0))))