summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-05-16 14:56:20 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-05-19 23:49:21 +0200
commit9b7dcc27031ddad451d75ed85a5681ff2210be00 (patch)
tree990f7ef2c3ecb01e2f212e96fac615c3f15d0ff6 /gnu/packages/ebook.scm
parenteeba7d3a076d0a9ed168c500d13afdb129199e56 (diff)
downloadpatches-9b7dcc27031ddad451d75ed85a5681ff2210be00.tar
patches-9b7dcc27031ddad451d75ed85a5681ff2210be00.tar.gz
gnu: calibre: Add missing dependencies.
* gnu/packages/ebook.scm (calibre)[inputs]: Add poppler, python2-dnspython, and python2-pygments. [arguments]: Remove old TODO comments. libwmf and psutil are no longer used. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 778b17c469..bf80d6650e 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -100,16 +100,9 @@
;; xdg-utils is supposed to be used for desktop integration, but it
;; also creates lots of messages
;; mkdir: cannot create directory '/homeless-shelter': Permission denied
+ ("python2-flake8" ,python2-flake8)
("xdg-utils" ,xdg-utils)))
- ;; FIXME: The following are missing inputs according to the documentation,
- ;; but the package can apparently be used without them,
- ;; They may need to be added if a deficiency is detected.
- ;; BeautifulSoup >= 3.0.5
- ;; dnspython >= 1.6.0
- ;; poppler >= 0.20.2
- ;; libwmf >= 0.2.8
- ;; psutil >= 0.6.1
- ;; python-pygments >= 2.0.1 ; used for ebook editing
+ ;; Beautifulsoup3 is bundled but obsolete and not packaged, so just leave it bundled.
(inputs
`(("chmlib" ,chmlib)
("fontconfig" ,fontconfig)
@@ -121,6 +114,7 @@
("libxrender" ,libxrender)
("openssl" ,openssl)
("podofo" ,podofo)
+ ("poppler" ,poppler)
("python" ,python-2)
("python2-apsw" ,python2-apsw)
("python2-chardet" ,python2-chardet)
@@ -128,12 +122,14 @@
("python2-cssutils" ,python2-cssutils)
("python2-dateutil" ,python2-dateutil)
("python2-dbus" ,python2-dbus)
+ ("python2-dnspython" ,python2-dnspython)
("python2-feedparser" ,python2-feedparser)
("python2-lxml" ,python2-lxml)
("python2-markdown" ,python2-markdown)
("python2-mechanize" ,python2-mechanize)
("python2-netifaces" ,python2-netifaces)
("python2-pillow" ,python2-pillow)
+ ("python2-pygments" ,python2-pygments)
("python2-pyqt" ,python2-pyqt)
("python2-sip" ,python2-sip)
("sqlite" ,sqlite)))