summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-03-16 10:12:47 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:04:31 +0000
commit0573a923def01e54bf104e0015ade44ab42f694f (patch)
tree43017c50ea559477064a01570e11de5127775a64 /gnu/packages/documentation.scm
parentf6292baf922da363351066a7d280722068b246e4 (diff)
downloadpatches-0573a923def01e54bf104e0015ade44ab42f694f.tar
patches-0573a923def01e54bf104e0015ade44ab42f694f.tar.gz
gnu: Move asciidoc and doxygen to new module.
* gnu/packages/asciidoc.scm (asciidoc): Move this... * gnu/packages/doxygen.scm (doxygen): ...and this... * gnu/packages/documentation.scm: ...to here. New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add accordingly.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
new file mode 100644
index 0000000000..567669a3b6
--- /dev/null
+++ b/gnu/packages/documentation.scm
@@ -0,0 +1,89 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages documentation)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages graphviz)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages xml)
+ #:autoload (gnu packages zip) (unzip))
+
+(define-public asciidoc
+ (package
+ (name "asciidoc")
+ (version "8.6.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/asciidoc/asciidoc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1w71nk527lq504njmaf0vzr93pgahkgzzxzglrq6bay8cw2rvnvq"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no 'check' target
+ (inputs `(("python" ,python-2)))
+ (home-page "http://www.methods.co.nz/asciidoc/")
+ (synopsis "Text-based document generation system")
+ (description
+ "AsciiDoc is a text document format for writing notes, documentation,
+articles, books, ebooks, slideshows, web pages, man pages and blogs.
+AsciiDoc files can be translated to many formats including HTML, PDF,
+EPUB, man page.
+
+AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
+the backend output markups (which can be almost any type of SGML/XML
+markup) can be customized and extended by the user.")
+ (license gpl2+)))
+
+(define-public doxygen
+ (package
+ (name "doxygen")
+ (version "1.8.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.stack.nl/pub/users/dimitri/"
+ name "-" version ".src.tar.gz"))
+ (sha256
+ (base32
+ "0ja02pm3fpfhc5dkry00kq8mn141cqvdqqpmms373ncbwi38pl35"))
+ (patches (search-patches "doxygen-test.patch"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("libxml2" ,libxml2) ; provides xmllint for the tests
+ ("python" ,python-2))) ; for creating the documentation
+ (arguments
+ `(#:test-target "tests"))
+ (home-page "http://www.stack.nl/~dimitri/doxygen/")
+ (synopsis "Generate documentation from annotated sources")
+ (description "Doxygen is the de facto standard tool for generating
+documentation from annotated C++ sources, but it also supports other popular
+programming languages such as C, Objective-C, C#, PHP, Java, Python,
+IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,
+and to some extent D.")
+ (license gpl3+)))