summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:35:51 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:16:22 -0500
commitb42c9c812403074ac0eaa57f9293972a5765e213 (patch)
treea639d9960caa461073a7a084a711e6ea44f899ba /gnu/packages/docker.scm
parentd020bfc2df1a9fe2ac765372ab9525f44914c873 (diff)
downloadpatches-b42c9c812403074ac0eaa57f9293972a5765e213.tar
patches-b42c9c812403074ac0eaa57f9293972a5765e213.tar.gz
gnu: Add python-dockerpty.
* gnu/packages/docker.scm (python-dockerpty): New variable.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 8b75590668..f2164213d4 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -50,3 +50,24 @@
(description "Docker-Py is a Python client for the Docker container
management tool.")
(license license:asl2.0)))
+
+(define-public python-dockerpty
+ (package
+ (name "python-dockerpty")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dockerpty" version))
+ (sha256
+ (base32
+ "0za6rr349641wv76ww9l3zcic2xyxrirlxpnzl4296h897648455"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/d11wtq/dockerpty")
+ (synopsis "Python library to use the pseudo-TTY of a Docker container")
+ (description "Docker PTY provides the functionality needed to operate the
+pseudo-terminal (PTY) allocated to a Docker container using the Python
+client.")
+ (license license:asl2.0)))