summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-30 14:32:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-30 14:32:53 +0100
commit998e6cdcd2a9fcce18b46676ce47990867227945 (patch)
tree5b6b08860183d164108257a3715e0c5673063f5a /gnu/packages/dns.scm
parenta557810ac72effd6841b76772195b10c03dee345 (diff)
parentd8bb1097d764949e80f9e41d26b3b194163dd716 (diff)
downloadpatches-998e6cdcd2a9fcce18b46676ce47990867227945.tar
patches-998e6cdcd2a9fcce18b46676ce47990867227945.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm28
1 files changed, 20 insertions, 8 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b072a43e11..ec4008bf19 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -273,21 +273,33 @@ the two.")
(define-public libasr
(package
(name "libasr")
- (version "201602131606")
+ (version "1.0.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.opensmtpd.org/archives/"
- name "-" version ".tar.gz"))
+ "libasr-" version ".tar.gz"))
(sha256
- (base32
- "18kdmbjsxrfai16d66qslp48b1zf7gr8him2jj5dcqgbsl44ls75"))))
+ (base32 "13fn4sr4vlcx1xijpl26nmnxawyls4lr5q3mi11jdm76f80qxn4w"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; ‘GNU build system bootstrapping not needed’, the default lies.
+ (lambda _
+ (invoke "sh" "./bootstrap")))
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "src/asr_run.3"
+ (string-append out "/share/man/man3"))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("groff" ,groff)))
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(home-page "https://www.opensmtpd.org")
(synopsis "Asynchronous resolver library by the OpenBSD project")
(description
@@ -373,14 +385,14 @@ to result in system-wide compromise.")
(define-public unbound
(package
(name "unbound")
- (version "1.9.3")
+ (version "1.9.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.unbound.net/downloads/unbound-"
version ".tar.gz"))
(sha256
- (base32 "1ykdy62sgzv33ggkmzwx2h0ifm7hyyxyfkb4zckv7gz4f28xsm8v"))))
+ (base32 "1c2bjm13x8bkw0ds1mhn9ivd2gzmfrb0x5y76bkz09a04bxjagix"))))
(build-system gnu-build-system)
(outputs '("out" "python"))
(native-inputs