summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
commitfc58cb5bd2f4a4fb9e910f553009fce8a60e56e9 (patch)
tree5a69fa6b63a7bfe7232cb98e949912c20775058d /gnu/packages/dns.scm
parent9d89818a359dd0657e4eb7649b29ad4197b8db39 (diff)
parentbad368b0d794689f3a8a11b58f1ea4987938682e (diff)
downloadpatches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar
patches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index bccc971109..869be47ad1 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +76,7 @@
(define-public dnsmasq
(package
(name "dnsmasq")
- (version "2.80")
+ (version "2.81")
(source (origin
(method url-fetch)
(uri (string-append
@@ -83,17 +84,7 @@
version ".tar.xz"))
(sha256
(base32
- "1fv3g8vikj3sn37x1j6qsywn09w1jipvlv34j3q5qrljbrwa5ayd"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; The SIOCGSTAMP ioctl is defined in <linux/sockios.h> instead
- ;; of <asm/sockios.h> starting with linux-libre-headers 5.2.
- ;; Remove this for dnsmasq versions > 2.80.
- (substitute* "src/dnsmasq.h"
- (("#if defined\\(HAVE_LINUX_NETWORK\\)" all)
- (string-append all "\n#include <linux/sockios.h>")))
- #t))))
+ "1yzq6anwgr5rlnwydpszb51cyhp2vjq29b24ck19flbwac1sk73l"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -315,7 +306,7 @@ the two.")
(synopsis "Asynchronous resolver library by the OpenBSD project")
(description
"libasr is a free, simple and portable asynchronous resolver library.
-It allows to run DNS queries and perform hostname resolutions in a fully
+It runs DNS queries and performs hostname resolution in a fully
asynchronous fashion.")
(license (list license:isc
license:bsd-2 ; last part of getrrsetbyname_async.c