summaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-01 00:02:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-01 00:02:39 +0200
commit571fb008a576378883c053be186d2c620290ea39 (patch)
tree5279a2c2772a9b76299a48d697d568f208a89722 /gnu/packages/dlang.scm
parent7c86fdda7ceed11377b0e17b47c91598be59be52 (diff)
parentf125c5a5ea03d53749f45d310694b79241d5888d (diff)
downloadpatches-571fb008a576378883c053be186d2c620290ea39.tar
patches-571fb008a576378883c053be186d2c620290ea39.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 2530b8a3c7..c164ed849a 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -103,12 +103,13 @@ and freshness without requiring additional information from the user.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((unpack (lambda (source target)
(with-directory-excursion target
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs source)
- "--strip-components=1"))))))
- (and (unpack "phobos-src" "runtime/phobos")
- (unpack "druntime-src" "runtime/druntime")
- (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite")))))
+ (invoke "tar" "xvf"
+ (assoc-ref inputs source)
+ "--strip-components=1")))))
+ (unpack "phobos-src" "runtime/phobos")
+ (unpack "druntime-src" "runtime/druntime")
+ (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite")
+ #t)))
(add-after 'unpack-submodule-sources 'patch-dmd2
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "dmd2/root/port.c"
@@ -210,12 +211,12 @@ bootstrapping more recent compilers written in D.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((unpack (lambda (source target)
(with-directory-excursion target
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs source)
- "--strip-components=1"))))))
- (and (unpack "phobos-src" "runtime/phobos")
- (unpack "druntime-src" "runtime/druntime")
- (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite")))))
+ (invoke "tar" "xvf"
+ (assoc-ref inputs source)
+ "--strip-components=1")))))
+ (unpack "phobos-src" "runtime/phobos")
+ (unpack "druntime-src" "runtime/druntime")
+ (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite"))))
(add-after 'unpack-submodule-sources 'patch-phobos
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("runtime/phobos/std/process.d"