summaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:16:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:05 +0200
commit454866c6e37cb8b1fa19d5a8e2e292c422360f30 (patch)
tree00f01abea124acfcbcc38de1101de2c382b7663e /gnu/packages/dlang.scm
parent6a6cfbafd7582e3625715059a972c5c0e647c606 (diff)
downloadpatches-454866c6e37cb8b1fa19d5a8e2e292c422360f30.tar
patches-454866c6e37cb8b1fa19d5a8e2e292c422360f30.tar.gz
gnu: dub: Don't use unstable tarball.
* gnu/packages/dlang.scm (dub)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 630270487d..3b0c799dc3 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -308,15 +308,16 @@ bootstrapping more recent compilers written in D.")
(package
(name "dub")
(version "1.7.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/dlang/dub/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1jvr1mmq8j77wnsrsg7x2xv8yfljqd6x8gn6yy7dd6h6y3cf408q"))))
- (build-system gnu-build-system)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlang/dub.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "073ibvgm1gphcqs1yjrav9ryp677nh3b194nxmvicwgvdc0sb6w9"))))
+ (build-system gnu-build-system)
(arguments
`(#:tests? #f ; it would have tested itself by installing some packages (vibe etc)
#:phases