summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-29 22:19:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 01:31:31 +0200
commit947134492eb60bc1dc2e2dbd9558f68911e1bb36 (patch)
treeb188d601bee18267db140f52b0aa73fac93bfe28 /gnu/packages/display-managers.scm
parent8d2d68a5fb1e581618cdf9b077fb2ddd1b9930da (diff)
downloadpatches-947134492eb60bc1dc2e2dbd9558f68911e1bb36.tar
patches-947134492eb60bc1dc2e2dbd9558f68911e1bb36.tar.gz
gnu: Remove greenisland.
* gnu/packages/display-managers.scm (greenisland): Remove variable.
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm82
1 files changed, 0 insertions, 82 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index afe5cc2b7b..15e7971b4f 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -49,88 +49,6 @@
#:use-module (gnu packages xfce)
#:use-module (gnu packages xorg))
-(define-public greenisland
- (package
- (name "greenisland")
- (version "0.9.0.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/greenisland/greenisland"
- "/releases/download/v" version "/"
- "greenisland-" version ".tar.xz"))
- (sha256
- (base32
- "1flmha31hmii6m2mdvmn1q5dc0fhnvgc4lp1b4wgkz20y7x4f1fm"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("dbus" ,dbus)
- ("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server)))
- (inputs
- `(("elogind" ,elogind)
- ("eudev" ,eudev)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("glib" ,glib)
- ("libdrm" ,libdrm)
- ("libinput" ,libinput-minimal)
- ("libxcursor" ,libxcursor)
- ("libxkbcommon" ,libxkbcommon)
- ("libx11" ,libx11)
- ("mesa" ,mesa)
- ("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)
- ("xcb-util-cursor" ,xcb-util-cursor)))
- (arguments
- `(#:configure-flags
- (list (string-append "-DPLUGIN_INSTALL_DIR="
- (assoc-ref %outputs "out") "/plugins")
- (string-append "-DQML_INSTALL_DIR="
- (assoc-ref %outputs "out") "/qml"))
- #:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-udev-tests
- (lambda _ ; FIXME: Build env doesn't contain /dev/sda
- (substitute* "tests/auto/platform/tst_udev.cpp"
- (("QVERIFY") "// QVERIFY")
- (("QCOMPARE") "// QCOMPARE"))))
- (replace 'check
- (lambda _
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "ctest" ".")))
- (add-before 'check 'check-setup
- (lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "XDG_RUNTIME_DIR" (getcwd))
- #t))
- (add-after 'install 'wrap-programs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "greenisland")
- (wrap-qt-program out "greenisland-launcher")
- (wrap-qt-program out "greenisland-screencaster")
- (wrap-qt-program out "greenisland-wayland-scanner")
- #t))))))
- (synopsis "QtQuick Wayland compositor and shell for desktop and mobile")
- (description "Green Island provides a full blown Wayland compositor for
-QtQuick as well as pluggable hardware abstraction, extensions, tools and a
-Qt-style API for Wayland clients.")
- (home-page "http://hawaiios.org")
- ;; Choice of license at the user's opinion.
- (license (list license:gpl2 license:gpl3 license:lgpl2.1 license:lgpl3))))
-
(define-public sddm
(package
(name "sddm")