summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-14 21:26:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 00:32:15 +0200
commitb3307bfdf9ebf6808fe15dce9fd2712db6f5b909 (patch)
treec9f4cbf0a11da7e413cb319bff79424694a1365c /gnu/packages/disk.scm
parent34ba1b8fc539c75fd7d03e44a242e023be82b2ab (diff)
downloadpatches-b3307bfdf9ebf6808fe15dce9fd2712db6f5b909.tar
patches-b3307bfdf9ebf6808fe15dce9fd2712db6f5b909.tar.gz
gnu: f3: Don't use unstable tarball.
* gnu/packages/disk.scm (f3)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 9d05b2444e..e101d33e25 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -398,13 +398,14 @@ systems. Output format is completely customizable.")
(version "6.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/AltraMayor/f3/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AltraMayor/f3.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1mgbzc1swvgil45md1336j0aqkmkhwmpxical0ln5g09b2qxsanp"))))
+ "1azi10ba0h9z7m0gmfnyymmfqb8380k9za8hn1rrw1s442hzgnz2"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no check target