summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-14 21:42:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 00:32:15 +0200
commitaf514eadb2ef77b890daab17f872350d009a4c18 (patch)
tree32a7ab71cc049d89ee702055a70b73225cbd790c /gnu/packages/disk.scm
parentb3307bfdf9ebf6808fe15dce9fd2712db6f5b909 (diff)
downloadpatches-af514eadb2ef77b890daab17f872350d009a4c18.tar
patches-af514eadb2ef77b890daab17f872350d009a4c18.tar.gz
gnu: f3: Update to 7.1.
* gnu/packages/disk.scm (f3): Update to 7.1. [arguments]: Remove ‘fix-makefile’ phase. Move installation of experimental (now called ‘extra’) tools to their own phases instead of cleverly patching Makefile.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index e101d33e25..f1b3f265fe 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -395,7 +395,7 @@ systems. Output format is completely customizable.")
(define-public f3
(package
(name "f3")
- (version "6.0")
+ (version "7.1")
(source
(origin
(method git-fetch)
@@ -405,25 +405,21 @@ systems. Output format is completely customizable.")
(file-name (git-file-name name version))
(sha256
(base32
- "1azi10ba0h9z7m0gmfnyymmfqb8380k9za8hn1rrw1s442hzgnz2"))))
+ "0zglsmz683jg7f9wc6vmgljyg9w87pbnjw5x4w6x02w8233zvjqf"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no check target
+ '(#:tests? #f ; no check target
#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- ;; Install without setting owner and group
- (("\\$\\(INSTALL\\) -oroot -groot ") "$(INSTALL) ")
- ;; also build and install experimental tools
- (("^all: ") "all: $(EXPERIMENTAL_TARGETS) ")
- (("^install: ") "install-all: ")
- (("^install-experimental: ") "install: install-all "))
- #t)))))
+ (delete 'configure) ; no configure script
+ (add-after 'build 'build-extra
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "extra" make-flags)))
+ (add-after 'build 'install-extra
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install-extra" make-flags))))))
(inputs
`(("eudev" ,eudev)
("parted" ,parted)))