summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-18 18:10:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-18 18:10:47 +0200
commitb95d1b3289a6bb8e346a47e750660e16fb201c57 (patch)
treecd4d956436f21d77645fd795d3e9737e4892c1d3 /gnu/packages/diffoscope.scm
parenta1d1703a1dc6bfcd10f48fe707ee7ac65300a37d (diff)
parentdabcfc6de29032ea52d1cb54163a783f7e480167 (diff)
downloadpatches-b95d1b3289a6bb8e346a47e750660e16fb201c57.tar
patches-b95d1b3289a6bb8e346a47e750660e16fb201c57.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 15d5a5787e..23acf0aeb8 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -67,7 +67,7 @@
#:use-module (ice-9 match))
(define-public diffoscope
- (let ((version "125"))
+ (let ((version "126"))
(package
(name "diffoscope")
(version version)
@@ -79,7 +79,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "02kwisp9j63w27hhcwpdhg66dgxzz61q4fcyfz8z4hwlz6r0gyqy"))))
+ "0lmn2116g5l05nns8qd2kwsnnd144zrqhs53fsr88inzf0mkqwhj"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -90,18 +90,6 @@
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
- ;; Patch in support for known tools
- (add-after 'unpack 'add-known-tools
- (lambda _
- (substitute* "diffoscope/external_tools.py"
- (("'arch': 'enjarify'},")
- "'arch': 'enjarify', 'guix': 'enjarify'},"))
- (substitute* "diffoscope/external_tools.py"
- (("'arch': 'python-jsbeautifier'},")
- "'arch': 'python-jsbeautifier', 'guix': 'python-jsbeautifier'},"))
- (substitute* "diffoscope/external_tools.py"
- (("'arch': 'wabt'},")
- "'arch': 'wabt', 'guix': 'wabt'},"))))
;; This test is broken because our `file` package has a
;; bug in berkeley-db file type detection.
(add-after 'unpack 'remove-berkeley-test