summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-08-14 01:20:14 -0500
committerEric Bavier <bavier@member.fsf.org>2015-08-14 01:22:18 -0500
commit61be05c3c39e5c4bb9775473bc32de2a608bbd0d (patch)
treefaeb0b31ad4ca65d57fdb73b949bf0fb1a5ea9f5 /gnu/packages/debug.scm
parentaf6100f51bf79efef0f79f90245790c410545513 (diff)
downloadpatches-61be05c3c39e5c4bb9775473bc32de2a608bbd0d.tar
patches-61be05c3c39e5c4bb9775473bc32de2a608bbd0d.tar.gz
gnu: c-reduce: Update to 2.3.0.
* gnu/packages/debug.scm (c-reduce): Update to 2.3.0. [inputs]: Use latest llvm and clang.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index a661dcef85..ba80711f01 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,7 +81,7 @@ program to exhibit a bug.")
(define-public c-reduce
(package
(name "c-reduce")
- (version "2.2.1")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
@@ -90,7 +90,7 @@ program to exhibit a bug.")
"creduce-" version ".tar.gz")))
(sha256
(base32
- "0wh0fkyg2l41d2wkndrgdiai9g2qiav7jik7cys21vmgzq01pyy2"))
+ "0r9lvnifjcnsrkrk8k4mha1kmmb93jya7alm523ck59y3173bpi0"))
(modules '((guix build utils)))
(snippet
'(substitute* "clang_delta/TransformationManager.cpp"
@@ -99,8 +99,8 @@ program to exhibit a bug.")
(inputs
`(("astyle" ,astyle)
("delta" ,delta)
- ("llvm" ,llvm-3.5)
- ("clang" ,clang-3.5)
+ ("llvm" ,llvm)
+ ("clang" ,clang)
("flex" ,flex)
("indent" ,indent)
("perl" ,perl)