summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-11-29 21:29:38 +0100
committerJohn Darrington <jmd@gnu.org>2016-11-29 21:32:09 +0100
commit660516e87556dfc39229cb6d319c9d1793efebb4 (patch)
treeb63fbb57d6849506c35257f82a1fe017d0ef02c8 /gnu/packages/debug.scm
parent7f81d7f4a5657a2f63336332a2581eafa26c6f66 (diff)
downloadpatches-660516e87556dfc39229cb6d319c9d1793efebb4.tar
patches-660516e87556dfc39229cb6d319c9d1793efebb4.tar.gz
gnu: Add zzuf
* gnu/packages/debug.scm (zzuf): New variable.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 54ed5cd36a..b7d6bbc0eb 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -314,3 +314,25 @@ no race conditions.")
;; and patched GNU Make is under its own license.
(license (list (non-copyleft "COPYING.md")
(package-license gnu-make))))))
+
+(define-public zzuf
+ (package
+ (name "zzuf")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/samhocevar/zzuf/releases/download/v"
+ version "/" name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mpzjaksc2qg2hzqflf39pl06p53qam2dn3hkhkcv6p00d2n4kx3"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/samhocevar/zzuf")
+ (synopsis "Transparent application input fuzzer")
+ (description "Zzuf is a transparent application input fuzzer. It works by
+intercepting file operations and changing random bits in the program's
+input. Zzuf's behaviour is deterministic, making it easy to reproduce bugs.")
+ (license (non-copyleft "http://www.wtfpl.net/txt/copying/"))))