summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
commitfc58cb5bd2f4a4fb9e910f553009fce8a60e56e9 (patch)
tree5a69fa6b63a7bfe7232cb98e949912c20775058d /gnu/packages/databases.scm
parent9d89818a359dd0657e4eb7649b29ad4197b8db39 (diff)
parentbad368b0d794689f3a8a11b58f1ea4987938682e (diff)
downloadpatches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar
patches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8e61c4afd2..09568aec37 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -225,7 +225,7 @@ standard Go idioms.")
(define-public ephemeralpg
(package
(name "ephemeralpg")
- (version "2.9")
+ (version "3.0")
(source
(origin
(method url-fetch)
@@ -233,17 +233,14 @@ standard Go idioms.")
"https://eradman.com/ephemeralpg/code/ephemeralpg-"
version ".tar.gz"))
(sha256
- (base32 "1ghp3kya4lxvfwz3c022cx9vqf55jbf9sjw60bxjcb5sszklyc89"))))
+ (base32 "1j0g7g114ma7y7sadbng5p1ss1zsm9zpicm77qspym6565733vvh"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "ruby" "test.rb")))
+ (delete 'configure) ; no configure script
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -255,11 +252,13 @@ standard Go idioms.")
"/bin")
;; For getsocket.
,(string-append out "/bin")))))
- #t)))))
+ #t)))
+ #:test-target "test"))
(inputs
`(("postgresql" ,postgresql)
("util-linux" ,util-linux)))
(native-inputs
+ ;; For tests.
`(("ruby" ,ruby)
("which" ,which)))
(home-page "https://eradman.com/ephemeralpg/")