summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-08 19:56:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 00:40:35 +0100
commit77e52190fa0cad22884bd7b59a69f9115ac82c3b (patch)
tree5913a88635321bcb0e3ce72e72a618d7e8757c3e /gnu/packages/databases.scm
parent507809be152049dff26bffdb58e1a90b638f046b (diff)
downloadpatches-77e52190fa0cad22884bd7b59a69f9115ac82c3b.tar
patches-77e52190fa0cad22884bd7b59a69f9115ac82c3b.tar.gz
gnu: rocksdb: Update to 5.1.2.
* gnu/packages/databases.scm (rocksdb): Update to 5.1.2. [native-inputs]: Add WHICH.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a358340baf..1ff6559883 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages crypto)
@@ -518,7 +519,7 @@ types are supported, as is encryption.")
(define-public rocksdb
(package
(name "rocksdb")
- (version "5.0.2")
+ (version "5.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/rocksdb"
@@ -526,7 +527,7 @@ types are supported, as is encryption.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1jj8b50w8jr3bnyjzk2hmlzq9x49yihjilx3xlq2rfdx3q9x4fay"))
+ "1qdbs13al7g45xc2j44wzx0ywrg32q1gsdhk5j6j4952xg91rfmh"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -581,7 +582,8 @@ types are supported, as is encryption.")
`(("parallel" ,parallel)
("perl" ,perl)
("procps" ,procps)
- ("python" ,python-2)))
+ ("python" ,python-2)
+ ("which" ,which)))
(inputs
`(("bzip2" ,bzip2)
("gflags" ,gflags)