summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-04 14:54:02 +0200
committerRoel Janssen <roel@gnu.org>2018-04-04 14:54:02 +0200
commitea09f99f7fcdde57589f83cfc66e813b084013f9 (patch)
tree97e2bc98109468e1d27542ee6d1272b290a0d0d6 /gnu/packages/databases.scm
parentb028a9830c5652c1c1782655c4cf268f4de7cc89 (diff)
downloadpatches-ea09f99f7fcdde57589f83cfc66e813b084013f9.tar
patches-ea09f99f7fcdde57589f83cfc66e813b084013f9.tar.gz
gnu: 4store: Remove preprocessor directive.
* gnu/packages/databases.scm (4store): Add patch to remove preprocessor directive. * gnu/packages/patches/4store-unset-preprocessor-directive.patch: New file. * gnu/local.mk: Register patch.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b08ac60f8c..30b9320c2a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -125,7 +125,8 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "004fmcf1w75zhc1x3zc6kc97j4jqn2v5nhk6yb3z3cpfrhzi9j50"))
- (patches (list (search-patch "4store-fix-buildsystem.patch")))))
+ (patches (search-patches "4store-unset-preprocessor-directive.patch"
+ "4store-fix-buildsystem.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)