summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-07 11:54:03 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-07 11:54:03 +0200
commitaeafff536f933b07836b14d089dfc52b0e432ec9 (patch)
tree4ede554999f98cf9e19c04098c934db52efae795 /gnu/packages/databases.scm
parent9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e (diff)
parentf82c58539e1f7b9b864e68ea2ab0c6a17c15fbb5 (diff)
downloadpatches-aeafff536f933b07836b14d089dfc52b0e432ec9.tar
patches-aeafff536f933b07836b14d089dfc52b0e432ec9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm42
1 files changed, 40 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 501377b7b7..80aa54f7a2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -55,7 +55,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages jemalloc)
#:use-module ((guix licenses)
- #:select (gpl2 gpl3+ lgpl2.1+ lgpl3+ x11-style non-copyleft
+ #:select (gpl2 gpl3 gpl3+ lgpl2.1+ lgpl3+ x11-style non-copyleft
bsd-2 bsd-3 public-domain))
#:use-module (guix packages)
#:use-module (guix download)
@@ -386,7 +386,7 @@ pictures, sounds, or video.")
(assoc-ref %build-inputs "bash:include")
"/include/bash"))))
- (native-inputs `(("emacs" ,emacs-no-x)
+ (native-inputs `(("emacs" ,emacs-minimal)
("bc" ,bc)
("bash:include" ,bash "include")
("libuuid" ,util-linux)))
@@ -919,3 +919,41 @@ sets, bitmaps and hyperloglogs.")
and B+ Tree data storage models. It is a fast key-value lightweight
database and supports many programming languages. It is a NoSQL database.")
(license gpl3+)))
+
+(define-public wiredtiger
+ (package
+ (name "wiredtiger")
+ (version "2.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://source.wiredtiger.com/releases/wiredtiger-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1qh7y5paisdxq19jgg81ld7i32lz920n5k30hdpxnr8ll9c4hgjr"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-lz4" "--enable-zlib")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-test/fops
+ (lambda _
+ ;; XXX: timed out after 3600 seconds of silence
+ (substitute* "Makefile"
+ (("test/fops") ""))
+ #t)))))
+ (inputs
+ `(("lz4" ,lz4)
+ ("zlib" ,zlib)))
+ (home-page "http://source.wiredtiger.com/")
+ (synopsis "NoSQL data engine")
+ (description
+ "WiredTiger is an extensible platform for data management. It supports
+row-oriented storage (where all columns of a row are stored together),
+column-oriented storage (where columns are stored in groups, allowing for
+more efficient access and storage of column subsets) and log-structured merge
+trees (LSM), for sustained throughput under random insert workloads.")
+ (license gpl3) ; or GPL-2
+ ;; configure.ac: WiredTiger requires a 64-bit build.
+ (supported-systems '("x86_64-linux" "mips64el-linux"))))