summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-28 14:45:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-28 14:45:35 +0200
commit7d62fa206b701504b110f253e3efb217eed475ad (patch)
tree8a2e44fb2560144d3b029085a560c1042e163423 /gnu/packages/databases.scm
parentc5db31d4141669d09c1cd8b37eb270c2fe23c7cf (diff)
parentcd8dce8ac4224d425f13b3c0776884c87ff43562 (diff)
downloadpatches-7d62fa206b701504b110f253e3efb217eed475ad.tar
patches-7d62fa206b701504b110f253e3efb217eed475ad.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 023ab84b75..74c0efe07b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -484,7 +484,7 @@ Language.")
(define-public mariadb
(package
(name "mariadb")
- (version "10.1.37")
+ (version "10.1.38")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.mariadb.org/f/"
@@ -492,7 +492,7 @@ Language.")
name "-" version ".tar.gz"))
(sha256
(base32
- "0ijdmdn9mcciwv361zfmja6b1h6qpbdqgrnnq6kkdapplyq1dmcc"))
+ "0zq77w3ff9q781fn8cv46vy1v4ggb8vjarjvk51k653x4gyg9wfa"))
(patches (search-patches "mariadb-client-test-32bit.patch"))
(modules '((guix build utils)))
(snippet
@@ -571,7 +571,7 @@ Language.")
"roles.acl_statistics"
;; This file contains a time bomb which makes it fail after
- ;; 2019-01-01. See <https://bugs.gnu.org/34351> for details.
+ ;; 2030-12-31. See <https://bugs.gnu.org/34351> for details.
"main.mysqldump"
;; XXX: Fails sporadically.
@@ -685,7 +685,7 @@ as a drop-in replacement of MySQL.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -704,6 +704,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")