summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-08 22:14:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-08 23:26:28 +0300
commit6ccb78144c78daf6d55edee6a6721565a0c4b520 (patch)
tree1217abb6048e727e79080ec2824ca976f1ff7287 /gnu/packages/databases.scm
parent1abd090487c1239fcfbd8628313e5aefbf577c61 (diff)
downloadpatches-6ccb78144c78daf6d55edee6a6721565a0c4b520.tar
patches-6ccb78144c78daf6d55edee6a6721565a0c4b520.tar.gz
gnu: tdb: Use 'modify-phases' syntax.
* gnu/packages/databases.scm (tdb)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c5fc9c7c71..b5c4ffcbdb 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -549,15 +549,15 @@ is in the public domain.")
"0i1l38h0vyck6zkcj4fn2l03spadlmyr1qa1xpdp9dy2ccbm3s1r"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; The 'configure' script is a wrapper for Waf and
- ;; doesn't recognize things like '--enable-fast-install'.
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; The 'configure' script is a wrapper for Waf and
+ ;; doesn't recognize things like '--enable-fast-install'.
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))))))
(native-inputs
`(;; TODO: Build the documentation.
;; ("docbook-xsl" ,docbook-xsl)