summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-10 20:11:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-10 20:11:26 +0100
commit2cbccf7f653d54fc41962425920db095d230de62 (patch)
tree69bc17d94ef3f89fea44589ac5bd46dc9a472bcc /gnu/packages/databases.scm
parent4730878b81a84e54408917c17f4b80e354423d61 (diff)
parentf10921c5ade56534633eae0da94da6e81aacc2aa (diff)
downloadpatches-2cbccf7f653d54fc41962425920db095d230de62.tar
patches-2cbccf7f653d54fc41962425920db095d230de62.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm34
1 files changed, 6 insertions, 28 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ed1d1fe95b..5137e31b05 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -881,6 +881,11 @@ Language.")
(rename-file (string-append out "/bin/mysql_config")
(string-append dev "/bin/mysql_config"))
+
+ (substitute* (string-append out "/bin/mysql_install_db")
+ (("\\$basedir/share/mysql")
+ (string-append lib "/share/mysql")))
+
;; Embed an absolute reference to OpenSSL in mysql_config
;; and the pkg-config file to avoid propagation.
(substitute* (list (string-append dev "/bin/mysql_config")
@@ -916,33 +921,6 @@ Language.")
as a drop-in replacement of MySQL.")
(license license:gpl2)))
-;; TODO: mysql_install_db is broken in MariaDB. This package is here as
-;; a workaround for packages that need it. Merge with 'mariadb' in the next
-;; rebuild cycle.
-(define-public mariadb/fixed-install-db
- (hidden-package
- (package/inherit
- mariadb
- (name "mariadb-fixed")
- (native-inputs '())
- (inputs
- `(("mariadb" ,mariadb)
- ("mariadb:lib" ,mariadb "lib")))
- (outputs '("out"))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules ((guix build utils)))
- (let ((out (assoc-ref %outputs "out")))
- (copy-recursively (assoc-ref %build-inputs "mariadb") out)
- (substitute* (string-append out "/bin/mysql_install_db")
- (("\\$basedir/share/mysql")
- (string-append (assoc-ref %build-inputs "mariadb:lib")
- "/share/mysql")))
- #t)))))))
-
(define-public mariadb-connector-c
(package
(name "mariadb-connector-c")
@@ -3305,7 +3283,7 @@ simultaneous database connections by using this framework.")
`(;; For tests.
("inetutils" ,inetutils)
("glibc-locales" ,glibc-locales)
- ("mariadb" ,mariadb/fixed-install-db)))
+ ("mariadb" ,mariadb)))
(inputs
`(("libdbi" ,libdbi)
("mariadb:dev" ,mariadb "dev")