summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-12 11:42:12 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-12 11:48:46 +0100
commite82e55e58c67b0215e768c4612ca542bc670f633 (patch)
tree856c4512fa1fbde59c1d9845c5a763ef8c4a14b4 /gnu/packages/databases.scm
parent98bd851ee891ca4a84e061fe1e78ba78c292b096 (diff)
parente35dff973375266db253747140ddf25084ecddc2 (diff)
downloadpatches-e82e55e58c67b0215e768c4612ca542bc670f633.tar
patches-e82e55e58c67b0215e768c4612ca542bc670f633.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7e669d633e..f45e3a5f1b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -55,6 +55,28 @@
#:use-module (srfi srfi-26)
#:use-module (ice-9 match))
+(define-public gdbm
+ (package
+ (name "gdbm")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gdbm/gdbm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hz3jgh3pd4qzp6jy0l8pd8x01g9abw7csnrlnj1a2sxy122z4cd"))))
+ (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/gdbm/")
+ (synopsis
+ "Hash library of database functions compatible with traditional dbm")
+ (description
+ "GDBM is a library for manipulating hashed databases. It is used to
+store key/value pairs in a file in a manner similar to the Unix dbm library
+and provides interfaces to the traditional file format.")
+ (license gpl3+)))
+
(define-public bdb
(package
(name "bdb")
@@ -602,6 +624,30 @@ columns, primary keys, unique constraints and relationships.")
(description "")
(license (package-license perl))))
+(define-public perl-dbd-mysql
+ (package
+ (name "perl-dbd-mysql")
+ (version "4.033")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CA/CAPTTOFU/"
+ "DBD-mysql-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0769xakykps0cx368g4vaips4w3bjk383rianiavq7sq6g6bp66c"))))
+ (build-system perl-build-system)
+ ;; Tests require running MySQL server
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("perl-dbi" ,perl-dbi)
+ ("mysql" ,mysql)))
+ (home-page "http://search.cpan.org/dist/DBD-mysql")
+ (synopsis "DBI MySQL interface")
+ (description "This package provides a MySQL driver for the Perl5
+@dfn{Database Interface} (DBI).")
+ (license (package-license perl))))
+
(define-public perl-dbd-sqlite
(package
(name "perl-dbd-sqlite")