summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-24 17:54:51 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-24 17:54:51 +0100
commitb5c18c78c2ff53fe3d489120d50f3732ee36d939 (patch)
tree1b3e4b3ccadf0cf79c4ad2dfd111eff48551dd69 /gnu/packages/curl.scm
parentc3f9761771d6a6bdafbe7626082d7c01599611d8 (diff)
downloadpatches-b5c18c78c2ff53fe3d489120d50f3732ee36d939.tar
patches-b5c18c78c2ff53fe3d489120d50f3732ee36d939.tar.gz
gnu: curl: Let patch-shebang handle /usr/bin/env.
* gnu/packages/curl.scm (curl): Drop manual rewriting of #!/usr/bin/env.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 00fd0f3232..4f5d96087e 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -55,18 +55,7 @@
("pkg-config" ,pkg-config)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("--with-gnutls" "--with-gssapi")
- #:phases
- (alist-replace
- 'unpack
- (lambda* (#:key #:allow-other-keys #:rest args)
- (let ((unpack (assoc-ref %standard-phases 'unpack)))
- (apply unpack args)
- ;; The following patch-shebang phase will replace perl
- ;; by the correct path.
- (substitute* "tests/runtests.pl"
- (("#!/usr/bin/env perl") "#!/usr/bin/perl"))))
- %standard-phases)))
+ `(#:configure-flags '("--with-gnutls" "--with-gssapi")))
(synopsis "curl, command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,