summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-02-18 21:45:58 +0100
committerAndreas Enge <andreas@enge.fr>2014-02-18 23:32:08 +0100
commitc0e57fb876b1bc996b3d30648f427dbf23bc99b4 (patch)
tree5c57a6a3a4377960d19062305881c2ca52205472 /gnu/packages/curl.scm
parent2977b307ef0035773d47285855cdbc8f2bade490 (diff)
downloadpatches-c0e57fb876b1bc996b3d30648f427dbf23bc99b4.tar
patches-c0e57fb876b1bc996b3d30648f427dbf23bc99b4.tar.gz
gnu: curl: Fix tests.
* gnu/packages/curl.scm (curl): Add a new phase and python-2 to native-inputs. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index ea7dbf6e21..7309da61e6 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages ssh))
(define-public curl
@@ -59,9 +60,18 @@
`(("perl" ,perl)
;; to enable the --manual option and make test 1026 pass
("groff" ,groff)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)))
(arguments
- `(#:configure-flags '("--with-gnutls" "--with-gssapi")))
+ `(#:configure-flags '("--with-gnutls" "--with-gssapi")
+ ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
+ #:phases
+ (alist-cons-before
+ 'check 'patch-runtests
+ (lambda _
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh"))))
+ %standard-phases)))
(synopsis "curl, command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,