summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-25 06:50:57 +0200
committerMark H Weaver <mhw@netris.org>2017-01-11 11:23:30 -0500
commitf8489f160b08deb4501ddc5e9cde911f6167ab1f (patch)
tree22363c7fae19f7e686b18a12e2a58da78ebad6dc /gnu/packages/cups.scm
parentb4c8c413cab95704b1d73af0ea4fcda61a716043 (diff)
downloadpatches-f8489f160b08deb4501ddc5e9cde911f6167ab1f.tar
patches-f8489f160b08deb4501ddc5e9cde911f6167ab1f.tar.gz
gnu: cups-filters: Update to 1.13.1.
* gnu/packages/cups.scm (cups-filters): Update to 1.13.1. [inputs]: Switch libjpeg-8 to libjpeg. [arguments]: Disable driverless printing, set location for bash shell.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index baa77f7aac..ca16958352 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -51,7 +51,7 @@
(define-public cups-filters
(package
(name "cups-filters")
- (version "1.11.5")
+ (version "1.13.1")
(source(origin
(method url-fetch)
(uri
@@ -59,7 +59,7 @@
"cups-filters-" version ".tar.xz"))
(sha256
(base32
- "1hcp1cfx1a71aa6fyayajjh7vw1ia7zya6981gz73vsy2pdb23qf"))
+ "0s7hylp2lcvc1vrqpywpv7lspkrh4xf7cyi4nbg10cf38rshj474"))
(modules '((guix build utils)))
(snippet
;; install backends, banners and filters to cups-filters output
@@ -85,12 +85,16 @@
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output))
#:configure-flags
- `(,(string-append "--with-test-font-path="
+ `("--disable-driverless" ; TODO: enable this
+ ,(string-append "--with-test-font-path="
(assoc-ref %build-inputs "font-dejavu")
"/share/fonts/truetype/DejaVuSans.ttf")
,(string-append "--with-gs-path="
(assoc-ref %build-inputs "ghostscript")
"/bin/gsc")
+ ,(string-append "--with-shell="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
,(string-append "--with-rcdir="
(assoc-ref %outputs "out") "/etc/rc.d"))))
(native-inputs
@@ -100,12 +104,12 @@
`(("avahi" ,avahi)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ("font-dejavu" ,font-dejavu) ;needed by test suite
+ ("font-dejavu" ,font-dejavu) ; also needed by test suite
("ghostscript" ,(force ghostscript/cups))
("ijs" ,ijs)
("dbus" ,dbus)
("lcms" ,lcms)
- ("libjpeg-8" ,libjpeg-8)
+ ("libjpeg" ,libjpeg)
("libpng" ,libpng)
("libtiff" ,libtiff)
("mupdf" ,mupdf)