summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-09-12 23:15:54 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-12 23:15:54 +0200
commitb263967018bd8d32578c4075d68c1d94664fc29a (patch)
treec15095b86439d712028669fe315b192ba0306fb3 /gnu/packages/cups.scm
parent1728c411718e3b358c06561d6e80b47d7b331617 (diff)
downloadpatches-b263967018bd8d32578c4075d68c1d94664fc29a.tar
patches-b263967018bd8d32578c4075d68c1d94664fc29a.tar.gz
gnu: cups-filters: Pass "--localstatedir".
* gnu/packages/cups.scm (cups-filters)[arguments]: Pass --localstatedir.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 879ec42a88..0e7fcce749 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -89,6 +89,10 @@
#:configure-flags
`("--disable-driverless" ; TODO: enable this
"--disable-mutool" ; depends on yet another PDF library (mupdf)
+
+ ;; Look for the "domain socket of CUPS" in /var/run/cups.
+ "--localstatedir=/var"
+
,(string-append "--with-test-font-path="
(assoc-ref %build-inputs "font-dejavu")
"/share/fonts/truetype/DejaVuSans.ttf")