summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-08-08 01:00:13 -0400
committerLeo Famulari <leo@famulari.name>2018-09-09 20:05:47 -0400
commitde15ff1a6c319a46046093d26baa6117c6a22e73 (patch)
treeb1d1b94e77d363596be1e93fea935e685b2e34e7 /gnu/packages/crypto.scm
parentd4bd2453ec6c2342d071cb9a9708280cf45b23ca (diff)
downloadpatches-de15ff1a6c319a46046093d26baa6117c6a22e73.tar
patches-de15ff1a6c319a46046093d26baa6117c6a22e73.tar.gz
gnu: Add asignify.
* gnu/packages/crypto.scm (asignify): New variable.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index d9111135e8..33f4abb5ae 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -816,3 +816,41 @@ which is also used in the Advanced Encryption Standard (AES, see
@url{http://www.nist.gov/aes}). This cipher is believed to provide very strong
security.")
(license license:gpl2)))
+
+(define-public asignify
+ (let ((commit "f58e7977a599f040797975d649ed318e25cbd2d5")
+ (revision "0"))
+ (package
+ (name "asignify")
+ (version (git-version "1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vstakhov/asignify.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zl68qq6js6fdahxzyhvhrpyrwlv8c2zhdplycnfxyr1ckkhq8dw"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-openssl"
+ (string-append "--with-openssl="
+ (assoc-ref %build-inputs "openssl")))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("openssl" ,openssl-next)))
+ (home-page "https://github.com/vstakhov/asignify")
+ (synopsis "Cryptographic authentication and encryption tool and library")
+ (description "Asignify offers public cryptographic signatures and
+encryption with a library or a command-line tool. The tool is heavily inspired
+by signify as used in OpenBSD. The main goal of this project is to define a
+high level API for signing files, validating signatures and encrypting using
+public-key cryptography. Asignify is designed to be portable and self-contained
+with zero external dependencies. Asignify can verify OpenBSD signatures, but it
+cannot sign messages in OpenBSD format yet.")
+ (license license:bsd-2))))