summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 21:16:27 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:58 +0200
commitc28a8ff9324c6379b6650215f610b93787d7889a (patch)
treef69875712629f4a9fe792cb50900b8767f0a242c /gnu/packages/crates-io.scm
parent4e6586c8d7af78d5fee30cdb5431b5228f7e5faa (diff)
downloadpatches-c28a8ff9324c6379b6650215f610b93787d7889a.tar
patches-c28a8ff9324c6379b6650215f610b93787d7889a.tar.gz
gnu: Add rust-ordermap-0.3.
* gnu/packages/crates-io.scm (rust-ordermap-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5d709bc610..31a9b4942a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6058,6 +6058,39 @@ system for OpenSSL.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-ordermap-0.3
+ (package
+ (name "rust-ordermap")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ordermap" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qr0a50l0qakbjcck93qdayd0xl8gzpp42x0n7b75cs4ybsx6vm8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-serde" ,rust-serde-1.0))
+ #:cargo-development-inputs
+ (("rust-fnv" ,rust-fnv-1.0)
+ ("rust-itertools" ,rust-itertools-0.8)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-quickcheck" ,rust-quickcheck-0.8)
+ ("rust-rand" ,rust-rand-0.4)
+ ("rust-serde-test" ,rust-serde-test-1.0))))
+ (home-page "https://github.com/bluss/indexmap")
+ (synopsis "Hash table with consistent order and fast iteration")
+ (description
+ "This package provides a hash table with consistent order and fast
+iteration. NOTE: This crate was renamed to @code{indexmap}. Please use it
+under its new name.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-os-pipe-0.8
(package
(name "rust-os-pipe")