summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-11-29 12:15:33 +0100
committerRoel Janssen <roel@gnu.org>2017-11-29 12:15:33 +0100
commit94989d4baee8c7e02f7f39256be559e2d653ad4a (patch)
tree66884f6d40d44b313f75c14981d4f070c1e19cb6 /gnu/packages/cran.scm
parent3519f2841d459271600bd1a41f0f3c6eb8b009aa (diff)
downloadpatches-94989d4baee8c7e02f7f39256be559e2d653ad4a.tar
patches-94989d4baee8c7e02f7f39256be559e2d653ad4a.tar.gz
gnu: cran: Add r-rmpi.
* gnu/packages/cran.scm (r-rmpi): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9eb54c0358..4de3066834 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages mpi)
#:use-module (gnu packages perl)
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
@@ -601,6 +603,29 @@ and other distributions related to the eigenvalues of large Wishart
matrices.")
(license license:bsd-3)))
+(define-public r-rmpi
+ (package
+ (name "r-rmpi")
+ (version "0.6-6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "Rmpi" version))
+ (sha256
+ (base32
+ "0fm6z049aaq2c9xagm8n64d9560hg9d8hyb0m359fii672nhkz6q"))))
+ (properties `((upstream-name . "Rmpi")))
+ (build-system r-build-system)
+ (arguments
+ `(#:configure-flags '("--configure-args=\"--with-Rmpi-type=OPENMPI\"")))
+ (inputs
+ `(("openmpi" ,openmpi)))
+ (home-page "http://www.stats.uwo.ca/faculty/yu/Rmpi")
+ (synopsis "R interface to message-passing interface (MPI)")
+ (description
+ "This package provides an interface (wrapper) to MPI APIs. It also
+provides an interactive R manager and worker environment.")
+ (license license:gpl2+)))
+
(define-public r-lmoments
(package
(name "r-lmoments")