summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:43:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:09 +0200
commitf2e974e1a2c1ef1341484d852123fc88919621af (patch)
tree713799e97da7926d04fd6b79eede2c70b427d422 /gnu/packages/cran.scm
parente0268ff2e404ca963f25d89fb52178768da0b856 (diff)
downloadpatches-f2e974e1a2c1ef1341484d852123fc88919621af.tar
patches-f2e974e1a2c1ef1341484d852123fc88919621af.tar.gz
gnu: Add r-fastmatch.
* gnu/packages/cran.scm (r-fastmatch): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index abdff54db9..c959beee0e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -366,3 +366,24 @@ compare different dendrograms to one another.")
powerful Perl module @code{Getopt::Long} and with some adaptation for easier
use in R. It also provides a simple way for variable interpolation in R.")
(license license:gpl2+)))
+
+(define-public r-fastmatch
+ (package
+ (name "r-fastmatch")
+ (version "1.1-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastmatch" version))
+ (sha256
+ (base32
+ "0z80jxkygmzn11sq0c2iz357s9bpki548lg926g85gldhfj1md90"))))
+ (build-system r-build-system)
+ (home-page "http://www.rforge.net/fastmatch")
+ (synopsis "Fast match function")
+ (description
+ "This package provides a fast @code{match} replacement for cases that
+require repeated look-ups. It is slightly faster that R's built-in
+@code{match} function on first match against a table, but extremely fast on
+any subsequent lookup as it keeps the hash table in memory.")
+ (license license:gpl2)))