summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-11 02:55:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-18 11:33:25 +0200
commitba4527ab94484ab7c01139428cb713708c0148e0 (patch)
tree348860b91593040c2f8c49a17ed4eec99751ddda /gnu/packages/cran.scm
parent6c3d42d61339f6728d7fec4e688caee24183ffc0 (diff)
downloadpatches-ba4527ab94484ab7c01139428cb713708c0148e0.tar
patches-ba4527ab94484ab7c01139428cb713708c0148e0.tar.gz
gnu: Add r-recipes.
* gnu/packages/cran.scm (r-recipes): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b42e791e95..691ed59aab 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1177,3 +1177,40 @@ provided.")
classification and bagging for classification, regression and survival
problems as well as resampling based estimators of prediction error.")
(license license:gpl2+)))
+
+(define-public r-recipes
+ (package
+ (name "r-recipes")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "recipes" version))
+ (sha256
+ (base32
+ "0rydk403qihxmcv3zz323r3ywk4g1v7ibvj452rxhm0z22sqk9kb"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ddalpha" ,r-ddalpha)
+ ("r-dimred" ,r-dimred)
+ ("r-dplyr" ,r-dplyr)
+ ("r-gower" ,r-gower)
+ ("r-ipred" ,r-ipred)
+ ("r-lubridate" ,r-lubridate)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rcpproll" ,r-rcpproll)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyselect" ,r-tidyselect)
+ ("r-timedate" ,r-timedate)))
+ (home-page "https://github.com/topepo/recipes")
+ (synopsis "Preprocessing tools to create design matrices")
+ (description
+ "Recipes is an extensible framework to create and preprocess design
+matrices. Recipes consist of one or more data manipulation and analysis
+\"steps\". Statistical parameters for the steps can be estimated from an
+initial data set and then applied to other data sets. The resulting design
+matrices can then be used as inputs into statistical or machine learning
+models.")
+ (license license:gpl2)))