summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 23:07:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 23:07:20 +0100
commitd976454c6b65264eb1be6b69852a69fe5f6cf6e1 (patch)
tree2fa2e29e33461bcd0d809049dacaf087f662353c /gnu/packages/cran.scm
parent7b81a7eabf71ccf989d2b3e33ff7d1801b848558 (diff)
downloadpatches-d976454c6b65264eb1be6b69852a69fe5f6cf6e1.tar
patches-d976454c6b65264eb1be6b69852a69fe5f6cf6e1.tar.gz
gnu: Add r-np.
* gnu/packages/cran.scm (r-np): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d20635b91b..14351e6ae0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2689,3 +2689,27 @@ of the sorts of data frequently encountered in phonetics research and
experimentation, including the easy creation of IPA vowel plots, and the
creation and manipulation of WAVE audio files.")
(license license:bsd-2)))
+
+(define-public r-np
+ (package
+ (name "r-np")
+ (version "0.60-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "np" version))
+ (sha256
+ (base32
+ "1y72x5j9j9mcgcy2xizk31gl843hfkngxdn8s4qw7yhw2qj79hsr"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)
+ ("r-cubature" ,r-cubature)
+ ("r-quantreg" ,r-quantreg)))
+ (home-page "https://github.com/JeffreyRacine/R-Package-np")
+ (synopsis "Non-parametric kernel smoothing methods for mixed data types")
+ (description "This package provides non-parametric (and semi-parametric)
+kernel methods that seamlessly handle a mix of continuous, unordered, and
+ordered factor data types.")
+ ;; Any version of the GPL.
+ (license license:gpl3+)))