summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 10:03:44 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:57 +0200
commitd7637e5ed8463d0c1ef84b1a6ef5b45205fdba26 (patch)
treeb98d9b14101ff2c14d699ade7c4a3795a0584bd8 /gnu/packages/cran.scm
parent9a91c925f2e4a4d021b417729e77284dd11ca789 (diff)
downloadpatches-d7637e5ed8463d0c1ef84b1a6ef5b45205fdba26.tar
patches-d7637e5ed8463d0c1ef84b1a6ef5b45205fdba26.tar.gz
gnu: Add r-readxl.
* gnu/packages/cran.scm (r-readxl): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 49bd835791..6bf3955fd6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,32 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
+(define-public r-readxl
+ (package
+ (name "r-readxl")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "readxl" version))
+ (sha256
+ (base32
+ "1bf7gxw9r11m4llyymplxiaa4gzgyj4bwmwad5in756pzq3jzmpv"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cellranger" ,r-cellranger)
+ ("r-rcpp" ,r-rcpp)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://readxl.tidyverse.org")
+ (synopsis "Read Excel files")
+ (description
+ "This package lets you import Excel files into R. It supports
+@file{.xls} via the embedded @code{libxls} C library and @file{.xlsx} via
+the embedded @code{RapidXML} C++ library.")
+ ;; XXX: This package bundles a copy of 'libxsl' which is BSD-2 and
+ ;; 'rapidxml' which is Boost.
+ (license (list license:gpl3 license:bsd-2 license:boost1.0))))
+
(define-public r-modelr
(package
(name "r-modelr")