summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-10 00:35:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-18 11:33:24 +0200
commitf97ce81575208eb673cb245d716b67bc61ec1a31 (patch)
tree0efa0cb645414c0da87020a72ca6a64fc1481864 /gnu/packages/cran.scm
parent851cb6dd3996ef72ad7c23bd588f8ffb64a2c21e (diff)
downloadpatches-f97ce81575208eb673cb245d716b67bc61ec1a31.tar
patches-f97ce81575208eb673cb245d716b67bc61ec1a31.tar.gz
gnu: Add r-cvst.
* gnu/packages/cran.scm (r-cvst): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 80335c4686..05fdde929d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23,6 +23,7 @@
#:use-module (guix utils)
#:use-module (guix build-system r)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages statistics)
@@ -928,3 +929,34 @@ sampling from populations, given the observed tie pattern. Except for Steel's
test and the JT test it also combines these tests across several blocks of
samples.")
(license license:gpl2+)))
+
+(define-public r-cvst
+ (package
+ (name "r-cvst")
+ (version "0.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "CVST" version))
+ (sha256
+ (base32
+ "17xacyi8cf37rr2xswx96qy7pwkaqq394awdlswykz3qlyzx4zx2"))))
+ (properties `((upstream-name . "CVST")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-kernlab" ,r-kernlab)
+ ("r-matrix" ,r-matrix)))
+ (home-page "http://cran.r-project.org/web/packages/CVST")
+ (synopsis "Fast cross-validation via sequential testing")
+ (description
+ "This package implements the fast cross-validation via sequential
+testing (CVST) procedure. CVST is an improved cross-validation procedure
+which uses non-parametric testing coupled with sequential analysis to
+determine the best parameter set on linearly increasing subsets of the data.
+Additionally to the CVST the package contains an implementation of the
+ordinary k-fold cross-validation with a flexible and powerful set of helper
+objects and methods to handle the overall model selection process. The
+implementations of the Cochran's Q test with permutations and the sequential
+testing framework of Wald are generic and can therefore also be used in other
+contexts.")
+ (license license:gpl2+)))