summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 22:52:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:11 +0200
commit8c72b830968a50a6f446bcfe18581f1d04ddb169 (patch)
treeebf85f38b5fe392ed4e55c0c48d4c21116569a4c /gnu/packages/cran.scm
parentd6b156dc049a8d808792249df36cd84ce70dca3f (diff)
downloadpatches-8c72b830968a50a6f446bcfe18581f1d04ddb169.tar
patches-8c72b830968a50a6f446bcfe18581f1d04ddb169.tar.gz
gnu: Add r-bbmle.
* gnu/packages/cran.scm (r-bbmle): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9e50eed3cd..e604799c4e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -709,3 +709,28 @@ and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
@code{.Call} calling conventions.")
;; Any version of the LGPL.
(license license:lgpl3+)))
+
+(define-public r-bbmle
+ (package
+ (name "r-bbmle")
+ (version "1.0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bbmle" version))
+ (sha256
+ (base32
+ "014h6mw16gv4acs2p78dy7lla7s428n633aybsb1mbi6250dg0p8"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-numderiv" ,r-numderiv)))
+ (home-page "http://cran.r-project.org/web/packages/bbmle")
+ (synopsis "Tools for General Maximum Likelihood Estimation")
+ (description
+ "Methods and functions for fitting maximum likelihood models in R. This
+package modifies and extends the @code{mle} classes in the @code{stats4}
+package.")
+ ;; Any version of the GPL
+ (license (list license:gpl2 license:gpl3))))