summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-22 23:45:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-22 23:48:57 +0200
commit056468dc5fe8edcce513b2f962156d8b56fc0b04 (patch)
treeca4b02b8ddf5dc1cc30dab8d9d1ca1cbf8475288 /gnu/packages/cran.scm
parent30f8349efb31dc1fb1bf628ee0e609683da311c3 (diff)
downloadpatches-056468dc5fe8edcce513b2f962156d8b56fc0b04.tar
patches-056468dc5fe8edcce513b2f962156d8b56fc0b04.tar.gz
gnu: Add cran module.
* gnu/packages/cran.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/statistics.scm (r-colorspace): Move to cran.scm.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
new file mode 100644
index 0000000000..9ebfbbed2d
--- /dev/null
+++ b/gnu/packages/cran.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cran)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system r))
+
+(define-public r-colorspace
+ (package
+ (name "r-colorspace")
+ (version "1.3-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "colorspace" version))
+ (sha256
+ (base32 "0d1ya7hx4y58n5ivwmdmq2zgh0g2sbv7ykh13n85c1355csd57yx"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/colorspace")
+ (synopsis "Color space manipulation")
+ (description
+ "This package carries out a mapping between assorted color spaces
+including RGB, HSV, HLS, CIEXYZ, CIELUV, HCL (polar CIELUV), CIELAB and polar
+CIELAB. Qualitative, sequential, and diverging color palettes based on HCL
+colors are provided.")
+ (license license:bsd-3)))