summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-11-09 16:47:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 18:04:37 +0100
commitda256afb9ed35bb15e7cab01a3aab76f1ec5639d (patch)
tree897cbbe0cd982970810bb303d95ef7d0d54dade1 /gnu/packages/cran.scm
parent4106e6ad87cb9b4bd571bc1a91cb026719770095 (diff)
downloadpatches-da256afb9ed35bb15e7cab01a3aab76f1ec5639d.tar
patches-da256afb9ed35bb15e7cab01a3aab76f1ec5639d.tar.gz
gnu: Add r-ks.
* gnu/packages/cran.scm (r-ks): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 604ba951c6..8c5c9258a9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7463,3 +7463,35 @@ to colexicographical order.")
isosurfaces.")
;; Any version of the GPL.
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-ks
+ (package
+ (name "r-ks")
+ (version "1.11.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ks" version))
+ (sha256
+ (base32
+ "0z749c3xzpf6n0g7xcfplrhap1di8k7kcfr7vigh95ywnigyhs8d"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fnn" ,r-fnn)
+ ("r-kernlab" ,r-kernlab)
+ ("r-kernsmooth" ,r-kernsmooth)
+ ("r-matrix" ,r-matrix)
+ ("r-mclust" ,r-mclust)
+ ("r-mgcv" ,r-mgcv)
+ ("r-misc3d" ,r-misc3d)
+ ("r-multicool" ,r-multicool)
+ ("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "http://www.mvstat.net/tduong/")
+ (synopsis "Kernel smoothing")
+ (description
+ "This package provides kernel smoothers for univariate and multivariate
+data, including density functions, density derivatives, cumulative
+distributions, modal clustering, discriminant analysis, and two-sample
+hypothesis testing.")
+ ;; Either version of the GPL.
+ (license (list license:gpl2 license:gpl3))))