summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-07 22:09:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 23:52:35 +0100
commitdab3e92c94ef86bd4eaf1c3f52f7ffdedcc7bd4f (patch)
treefa2789561286a69204acc1f542053332a30433a2 /gnu/packages/cran.scm
parent3f22a115bd792af0ce8cee9f0723c5f5fada0b2d (diff)
downloadpatches-dab3e92c94ef86bd4eaf1c3f52f7ffdedcc7bd4f.tar
patches-dab3e92c94ef86bd4eaf1c3f52f7ffdedcc7bd4f.tar.gz
gnu: Add r-magick.
* gnu/packages/cran.scm (r-magick): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb7689ecdb..b3378322d1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages javascript)
#:use-module (gnu packages lisp)
#:use-module (gnu packages machine-learning)
@@ -7132,6 +7133,39 @@ replicating the evaluation as many times as specified, and returning the results
conveniently wrapped into a data frame.")
(license license:gpl2+)))
+(define-public r-magick
+ (package
+ (name "r-magick")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "magick" version))
+ (sha256
+ (base32
+ "18y465325mhf48x2jn3jz9khwq1z2aj13wfbdkv8k3hln1sd572m"))))
+ (build-system r-build-system)
+ (inputs
+ `(("imagemagick" ,imagemagick)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/ropensci/magick")
+ (synopsis "Advanced graphics and image-processing in R")
+ (description
+ "This package provides bindings to ImageMagick, a comprehensive image
+processing library. It supports many common formats (PNG, JPEG, TIFF, PDF,
+etc.) and manipulations (rotate, scale, crop, trim, flip, blur, etc). All
+operations are vectorized via the Magick++ STL meaning they operate either on
+a single frame or a series of frames for working with layers, collages, or
+animation. In RStudio, images are automatically previewed when printed to the
+console, resulting in an interactive editing environment.")
+ (license license:expat)))
+
(define-public r-dvmisc
(package
(name "r-dvmisc")