summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 18:27:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commitc56a2440048575dcf4cfcf15222183ea58df5d48 (patch)
tree1ec936669d57fe8067a40d7a77d639adade821b5 /gnu/packages/cran.scm
parent7a19c76f00e9bd6444a2e1f3d313d66232df7d92 (diff)
downloadpatches-c56a2440048575dcf4cfcf15222183ea58df5d48.tar
patches-c56a2440048575dcf4cfcf15222183ea58df5d48.tar.gz
gnu: Add r-polycor.
* gnu/packages/cran.scm (r-polycor): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 92b48741d1..f024d0598d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19564,3 +19564,26 @@ for model selection, visualization, and estimation of topic-covariate
regressions.")
(license license:expat)))
+(define-public r-polycor
+ (package
+ (name "r-polycor")
+ (version "0.7-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "polycor" version))
+ (sha256
+ (base32
+ "0wzwzklflbhi8sv9m7ijwr16v9zmkk0j0v4pbcpf32f8lbn3psna"))))
+ (properties `((upstream-name . "polycor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "https://r-forge.r-project.org/projects/polycor/")
+ (synopsis "Polychoric and polyserial correlations")
+ (description
+ "This package provides tools to compute polychoric and polyserial
+correlations by quick \"two-step\" methods or ML, optionally with standard
+errors; tetrachoric and biserial correlations are special cases.")
+ (license license:gpl2+)))