summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:17:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:13 +0100
commit4b9bb70fa5389c326f35d9e71f2aace8d6875bc1 (patch)
treeee1b98944af2112e6898727f123e1139af97dca6 /gnu/packages/cran.scm
parenta21ff0724b3680732fcc48981d656f3656375be4 (diff)
downloadpatches-4b9bb70fa5389c326f35d9e71f2aace8d6875bc1.tar
patches-4b9bb70fa5389c326f35d9e71f2aace8d6875bc1.tar.gz
gnu: Add r-irtoys.
* gnu/packages/cran.scm (r-irtoys): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f307c116df..23d40f60e4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20194,3 +20194,33 @@ nonparametric Monte-Carlo Tests, itemfit and personfit statistics including
infit and outfit measures, ICC and other plots, automated stepwise item
elimination, and a simulation module for various binary data matrices.")
(license license:gpl3)))
+
+(define-public r-irtoys
+ (package
+ (name "r-irtoys")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "irtoys" version))
+ (sha256
+ (base32
+ "0h6iiaxikhbxhbyksbjnb09qdxinlkwr2v9yzs5wslbni14paq5q"))))
+ (properties `((upstream-name . "irtoys")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ltm" ,r-ltm)
+ ("r-sm" ,r-sm)))
+ (home-page "https://cran.r-project.org/package=irtoys")
+ (synopsis "Collection of functions related to Item Response Theory (IRT)")
+ (description
+ "This package provides a collection of functions useful in learning and
+practicing @dfn{Item Response Theory} (IRT), which can be combined into larger
+programs. It provides basic CTT analysis, a simple common interface to the
+estimation of item parameters in IRT models for binary responses with three
+different programs (ICL, BILOG-MG, and ltm), ability estimation (MLE, BME,
+EAP, WLE, plausible values), item and person fit statistics, scaling
+methods (MM, MS, Stocking-Lord, and the complete Hebaera method), and a rich
+array of parametric and non-parametric (kernel) plots. It estimates and plots
+Haberman's interaction model when all items are dichotomously scored.")
+ (license license:gpl2+)))