summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 18:32:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commit3385908e6b916b5b97b504fac47647eb60a92da1 (patch)
treeb64e6749223b852d703c648b0cb8e4609c59873e /gnu/packages/cran.scm
parentc56a2440048575dcf4cfcf15222183ea58df5d48 (diff)
downloadpatches-3385908e6b916b5b97b504fac47647eb60a92da1.tar
patches-3385908e6b916b5b97b504fac47647eb60a92da1.tar.gz
gnu: Add r-msm.
* gnu/packages/cran.scm (r-msm): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f024d0598d..adc4bd84fe 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19587,3 +19587,31 @@ regressions.")
correlations by quick \"two-step\" methods or ML, optionally with standard
errors; tetrachoric and biserial correlations are special cases.")
(license license:gpl2+)))
+
+(define-public r-msm
+ (package
+ (name "r-msm")
+ (version "1.6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "msm" version))
+ (sha256
+ (base32
+ "1d32y8f0vb2dfv3999liigpns788j145nrvd1xpxb9i2lsg8mwgk"))))
+ (properties `((upstream-name . "msm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-expm" ,r-expm)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-survival" ,r-survival)))
+ (home-page "https://github.com/chjackson/msm")
+ (synopsis "Multi-state Markov and hidden Markov models in continuous time")
+ (description
+ "This package provides functions for fitting continuous-time Markov and
+hidden Markov multi-state models to longitudinal data. It was designed for
+processes observed at arbitrary times in continuous time (panel data) but some
+other observation schemes are supported. Both Markov transition rates and the
+hidden Markov output process can be modelled in terms of covariates, which may
+be constant or piecewise-constant in time.")
+ (license license:gpl2+)))