summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 18:32:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commit07f3e9b93c8421e046f6af5635a059e065481799 (patch)
treef90b00dea83e5160968674ec0fe7985bfd2caa2d /gnu/packages/cran.scm
parent3385908e6b916b5b97b504fac47647eb60a92da1 (diff)
downloadpatches-07f3e9b93c8421e046f6af5635a059e065481799.tar
patches-07f3e9b93c8421e046f6af5635a059e065481799.tar.gz
gnu: Add r-ltm.
* gnu/packages/cran.scm (r-ltm): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index adc4bd84fe..238fc5c65a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19615,3 +19615,31 @@ other observation schemes are supported. Both Markov transition rates and the
hidden Markov output process can be modelled in terms of covariates, which may
be constant or piecewise-constant in time.")
(license license:gpl2+)))
+
+(define-public r-ltm
+ (package
+ (name "r-ltm")
+ (version "1.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ltm" version))
+ (sha256
+ (base32
+ "1qrgzwx5l58qf5rfp1knxc84r0g943q5sdr3ky74zzwpnmrf2vf7"))))
+ (properties `((upstream-name . "ltm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-msm" ,r-msm)
+ ("r-polycor" ,r-polycor)))
+ (home-page "https://github.com/drizopoulos/ltm")
+ (synopsis "Latent trait models under IRT")
+ (description
+ "This is a package supporting the analysis of multivariate dichotomous
+and polytomous data using latent trait models under the Item Response Theory
+approach. It includes the Rasch, the Two-Parameter Logistic, the Birnbaum's
+Three-Parameter, the Graded Response, and the Generalized Partial Credit
+Models.")
+ (license license:gpl2+)))
+