summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 16:59:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commite525c866d38b6c7498375f38eea7c92b0f7b6a4f (patch)
treeecf5cce33160ec878239464f6f6c5155bfcb7dee /gnu/packages/cran.scm
parent982a9fb6c64255205fb7e8c358f47f30f43710cf (diff)
downloadpatches-e525c866d38b6c7498375f38eea7c92b0f7b6a4f.tar
patches-e525c866d38b6c7498375f38eea7c92b0f7b6a4f.tar.gz
gnu: Add r-snowballc.
* gnu/packages/cran.scm (r-snowballc): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6bcc38c791..109616049c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19431,3 +19431,26 @@ analysis and natural language processing.")
"This package provides an R wrapper to the Python @dfn{natural language
processing} (NLP) library @code{spaCy}, from @url{http://spacy.io}.")
(license license:gpl3)))
+
+(define-public r-snowballc
+ (package
+ (name "r-snowballc")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SnowballC" version))
+ (sha256
+ (base32
+ "0b7pqdavf5jbf8si4ybnii5fff39p3b1rb5rym05j8s48hs7sqb1"))))
+ (properties `((upstream-name . "SnowballC")))
+ (build-system r-build-system)
+ (home-page "https://r-forge.r-project.org/projects/r-temis/")
+ (synopsis "Snowball stemmers based on the C libstemmer UTF-8 library")
+ (description
+ "This package provides an R interface to the C @code{libstemmer} library
+that implements Porter's word stemming algorithm for collapsing words to a
+common root to aid comparison of vocabulary. Currently supported languages
+are Danish, Dutch, English, Finnish, French, German, Hungarian, Italian,
+Norwegian, Portuguese, Romanian, Russian, Spanish, Swedish and Turkish.")
+ (license license:bsd-3)))