summaryrefslogtreecommitdiff
path: root/gnu/packages/cppi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-26 22:32:18 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-26 22:32:18 +0100
commit47a9cb950a181e7efa8af06f1c679ed0390a9164 (patch)
treee9e9b08f3375639b2e88a000aab38b854b478486 /gnu/packages/cppi.scm
parent128663e4c8e8e3c2a56686c6018641ce7bcf92da (diff)
downloadpatches-47a9cb950a181e7efa8af06f1c679ed0390a9164.tar
patches-47a9cb950a181e7efa8af06f1c679ed0390a9164.tar.gz
gnu: Add GNU cppi.
* gnu/packages/cppi.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages/cppi.scm')
-rw-r--r--gnu/packages/cppi.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/cppi.scm b/gnu/packages/cppi.scm
new file mode 100644
index 0000000000..53f24698fc
--- /dev/null
+++ b/gnu/packages/cppi.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cppi)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses))
+
+(define-public cppi
+ (package
+ (name "cppi")
+ (version "1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/cppi/cppi-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/cppi/")
+ (synopsis "A cpp directive indenter")
+ (description
+ "GNU cppi indents C preprocessor directives to reflect their nesting and
+ensure that there is exactly one space character between each #if, #elif,
+#define directive and the following token. The number of spaces between the
+`#' and the following directive must correspond to the level of nesting of
+that directive.")
+ (license gpl3+)))