summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 01:32:09 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 21:02:34 -0600
commit1ac40045029aacc2d360f4bd24d716c1306a54e8 (patch)
treed614eb775003d715edcf771fc2056ec0d311967d /gnu/packages/coq.scm
parentd977e243644c3ce6c6e7dc682b09ae409fcd8077 (diff)
downloadpatches-1ac40045029aacc2d360f4bd24d716c1306a54e8.tar
patches-1ac40045029aacc2d360f4bd24d716c1306a54e8.tar.gz
gnu: coq: Update to 8.10.2.
* gnu/packages/coq.scm (coq): Update to 8.10.2. [inputs]: Replace lablgtk with lablgtk3. [arguments]: Remove remove-lablgtk-references phase, as it no longer appears to be necessary.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 13ecd6c0ff..45aaa83711 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -44,7 +44,7 @@
(define-public coq
(package
(name "coq")
- (version "8.9.1")
+ (version "8.10.2")
(source
(origin
(method git-fetch)
@@ -53,7 +53,8 @@
(commit (string-append "V" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1p4z967s18wkblayv12ygqsrqlyk5ax1pz40yf4kag8pva6gblhk"))))
+ (base32
+ "0ji2rzd70b3hcwfw97qk7rv3m2977ylqnq82l1555dp3njr8nm3q"))))
(native-search-paths
(list (search-path-specification
(variable "COQPATH")
@@ -61,7 +62,7 @@
(build-system ocaml-build-system)
(outputs '("out" "ide"))
(inputs
- `(("lablgtk" ,lablgtk)
+ `(("lablgtk" ,lablgtk3)
("python" ,python-2)
("camlp5" ,camlp5)
("ocaml-num" ,ocaml-num)))
@@ -74,13 +75,6 @@
(lambda _
(for-each make-file-writable (find-files "."))
#t))
- (add-after 'unpack 'remove-lablgtk-references
- (lambda _
- ;; This is not used anywhere, but creates a reference to lablgtk in
- ;; every binary
- (substitute* '("config/coq_config.mli" "configure.ml")
- ((".*coqideincl.*") ""))
- #t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))