summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 02:20:41 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 21:08:19 -0600
commitcd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 (patch)
tree78b10a001e6ff658f2dd1187da23d42229335a51 /gnu/packages/coq.scm
parent8f1216552ceb02e8a16579637041d7b5f1eb96f3 (diff)
downloadpatches-cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523.tar
patches-cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523.tar.gz
gnu: coq-equations: Update to 1.2.1.
* gnu/packages/coq.scm (coq-equations): Update to 1.2.1. [arguments]: Replace configure phase to run configure shell script. Remove redundant COQLIB.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 08e0584e19..0bb9ce7c4a 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -549,16 +549,16 @@ uses Ltac to synthesize the substitution operation.")
(define-public coq-equations
(package
(name "coq-equations")
- (version "1.2")
+ (version "1.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mattam82/Coq-Equations.git")
- (commit (string-append "v" version "-8.9"))))
+ (commit (string-append "v" version "-8.10"))))
(file-name (git-file-name name version))
(sha256
(base32
- "1q3wvicr43bgy7xn1diwh4j43mnrhprrc2xd22qlbz9cl6bhf8bj"))))
+ "023q5dww3drw35dm9bi9p9d0wrj9k7vax7hfdsprf8l340pb4s0k"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)
@@ -570,10 +570,9 @@ uses Ltac to synthesize the substitution operation.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (invoke "coq_makefile" "-f" "_CoqProject" "-o" "Makefile")))
+ (invoke "sh" "./configure.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
(invoke "make"
(string-append "COQLIB=" (assoc-ref outputs "out")
"/lib/coq/")